Loading... Please wait...
  • +1-858-259-9388
  • My Account 

Currency Displayed in

pfSense® News

pfSense® News

pfSense Software Version 2.4-RELEASE Highlights

Team pfSense continues to move the world’s largest Open Source firewall forward with the completion of development and upcoming release of pfSense version 2.4. This is a short overview of brand new features and changes we’re excited to bring forward to the community. The full feature list is available as always on our wiki.



pfSense 2.3.4-p1 RELEASE Now Available!

pfSense software version 2.3.4-p1 is now available! This is a maintenance/errata patch available by running an update from an existing installation and it does not have a standalone installer to download.



Important update for OpenVPN

OpenVPN was analyzed by Guido Vranken using a fuzzer, which uncovered several vulnerabilities. Some of these vulnerabilities have the potential to be remotely exploitable in certain circumstances. For the full details, read the security advisory issued by OpenVPN. These vulnerabilities have been assigned IDs CVE-2017-7508, CVE-2017-7520, CVE-2017-7521, and CVE-2017-7522.



pfSense Brand Refresh

On Monday, June 5, 2017, Netgate®, the host of the pfSense® Project, unveiled its new company brand, as well as an updated brand logo for pfSense software.

The pfSense distribution has been available as an open source firewall since 2006. As the undisputed leader of open source firewalls, pfSense now has over 600,000 installs - providing IT security for consumer, businesses, higher education institutions, and government agencies on all seven continents.



Announcing Netgate Global Support!

Netgate Global Support has arrived! Netgate is very excited to announce our new multi-channel enterprise support offering to all of our customers. We believe that this new support structure will take our line of pfSense Security Gateway appliances to the next level by increasing your confidence that your pfSense firewall is covered when you need it the most. 



Introducing SG-2320 and SG-2340 appliances (UPDATED)

Update 24 May 2017

We have decided to withdraw the announced SG-2320 and SG-2340 pfSense security appliances from sale.

There is an underlying FreeBSD issue with the HDMI-based console that we foresee as a showstopper in the field for many of our customers and partners. We apologize for this, but we believe it is the right thing for everyone who relies on Netgate system and pfSense software to support their critical security infrastructure.



pfSense 2.3.4 RELEASE Now Available!

We are happy to announce the release of pfSense® software version 2.3.4!



Lord Vader, your firewall is ready

It’s May 4, and you know what that means…



More on AES-NI

There have been some concerns expressed about the requirement for AES-NI (or other offload) with pfSense 2.5, as announced two days ago.



pfSense 2.5 and AES-NI

We’re starting the process toward pfSense software release 2.3.4. pfSense software release 2.4 is close as well, and will bring a number of improvements: UEFI, translations to at least five lanuguages, ZFS, FreeBSD 11 base, new login page, OpenVPN 2.4 and more. pfSense version 2.4 requires a 64-bit Intel or AMD CPU, and nanobsd images are no longer a part of pfSense as of version 2.4.



 

What's News

newsletter

Copyright 2017 Tranquilnet, Inc. All Rights Reserved.
Sitemap

pfSense® is a registered trademark and service mark owned by Electric Sheep Fencing LLC